LISP 実際に設定した

 


CMLで。


xTR1

interface LISP0
!
interface GigabitEthernet0/0
 ip address 192.168.1.254 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.0.1.1 255.255.255.0
!
router lisp
 database-mapping 192.168.1.0/24 IPv4-interface GigabitEthernet0/1 priority 1 weight 100
 ipv4 itr map-resolver 10.0.3.3
 ipv4 itr
 ipv4 etr map-server 10.0.3.3 key password
 ipv4 etr
 exit
!
router ospf 1
 network 10.0.1.0 0.0.0.255 area 0


xTR2

interface LISP0
!
interface GigabitEthernet0/0
 ip address 192.168.2.254 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 10.0.2.2 255.255.255.0
!
router lisp
 database-mapping 192.168.2.0/24 IPv4-interface GigabitEthernet0/1 priority 1 weight 100
 ipv4 itr map-resolver 10.0.3.3
 ipv4 itr
 ipv4 etr map-server 10.0.3.3 key password
 ipv4 etr
 exit
!
router ospf 1
 network 10.0.2.0 0.0.0.255 area 0


MS/MR

interface GigabitEthernet0/0
 ip address 10.0.3.3 255.255.255.0
!
router lisp
 locator-set RLOC01
  IPv4-interface GigabitEthernet0/0 priority 1 weight 100
  exit
 !
 site SITE1
  authentication-key password
  eid-prefix 192.168.1.0/24
  exit
 !
 site SITE2
  authentication-key password
  eid-prefix 192.168.2.0/24
  exit
 !
 ipv4 map-server
 ipv4 map-resolver
 exit
!
router ospf 1
 network 10.0.3.0 0.0.0.255 area 0


確認
 
MSMR#show lisp site
LISP Site Registration Information
* = Some locators are down or unreachable
# = Some registrations are sourced by reliable transport

Site Name      Last      Up     Who Last             Inst     EID Prefix
               Register         Registered           ID       
SITE1          00:23:26  yes#   10.0.1.1                      192.168.1.0/24
SITE2          00:21:03  yes#   10.0.2.2                      192.168.2.0/24




xTR1#show ip lisp map-cache 
LISP IPv4 Mapping Cache for EID-table default (IID 0), 3 entries

0.0.0.0/0, uptime: 00:29:04, expires: never, via static send map-request
  Negative cache entry, action: send-map-request
192.168.2.0/24, uptime: 00:20:41, expires: 23:39:18, via map-reply, complete
  Locator   Uptime    State      Pri/Wgt
  10.0.2.2  00:20:41  up           1/100
192.168.10.0/24, uptime: 00:13:20, expires: 00:01:40, via map-reply, self, forward-native
  Negative cache entry, action: forward-native
xTR1#
xTR1#


xTR2#show ip lisp map-cache 
LISP IPv4 Mapping Cache for EID-table default (IID 0), 2 entries

0.0.0.0/0, uptime: 00:22:13, expires: never, via static send map-request
  Negative cache entry, action: send-map-request
192.168.1.0/24, uptime: 00:21:02, expires: 23:38:57, via map-reply, complete
  Locator   Uptime    State      Pri/Wgt
  10.0.1.1  00:21:02  up           1/100
---- 

192.168.1.111 のPCから ping 192.168.2.222 を実行したときの
Map requestはカプセル化されていた。

IP src(外): 10.0.1.1 ※ ITRの外側IPアドレス
IP dst(外): 10.0.3.3 ※ MRのIPアドレス
IP src(内): 192.168.2.222
IP dst(内): 192.168.2.222

ITR-RLOC Address: 10.0.1.1
Map-Request RecordのPrefix: 192.168.2.222
Map-Reply RecordのPrefix: 192.168.1.0/24




 














Map-Replyは、

IP src: 10.0.2.2
IP dst: 10.0.1.1
Mapping Record - EID Prefix: 192.168.2.0
Mappping Record - Locator Record - Local RLOC: 10.0.2.2



そしてicmp echo requestは

IP src(外): 10.0.1.1 ※ ITRの外側IPアドレス
IP dst(外): 10.0.2.2 ※ ETRの外側IPアドレス
IP src(内): 192.168.1.111
IP dst(内): 192.168.2.222

となっていた。

Map-RegisterとMap-Notifyは、etrを設定したときに送受信されるようだ。
もしくはdatabase mappingを設定したときか。

10.0.1.1 -> 10.0.3.3 に送信される。

この構成ではITR/ETR、MS/MRが同じなのでわからないが、

Map-Requestは
ITR -> MR

Map-Registerは
ETR -> MS

である。

Map-Requestは、「マッピングの解決要求」である。
『マッピングしてください』ではない。